В целом процесс обновления простой, нужно сделать следующее:

  1. Перезаписать файлы.
  2. Выполнить скрипт для обновления базы данных.

Но все же есть некоторые моменты, на которых стоит остановиться подробнее.

1️⃣ Основная версия программы и дополнение взаимосвязаны. Если  у вас установлено дополнение, то инструкцию по обновлению нужно выполнять полностью (обновлять основную версию и дополнение).

2️⃣ Если вы только купили Дополнение, но используете старую версию программы, то перед установкой дополнения обязательно обновите программу до текущей версии.

3️⃣ Рассмотрим ситуацию, когда вы используете очень старую версию программы, например 2.0 и вам необходимо обновится до текущей версии. 

4️⃣ Если вы используете дополнительный перевод, загрузите последнюю версию и обновите языковые файлы.

  1. Скачайте архив текущий версии и замените файлы. В архиве расположены обновления базы данных для всех версий.
  2. Выполните последовательно обновления базы данных с 2.0 до текущей версии.
Версия Основная Дополнение
1.8 /install/autoupdate/from_1.7_to_1.8.php
/install/autoupdate/data_prepare_from_1.7_to_1.8.php
Важно: дождитесь сообщения ОК по каждой сущности!
/install/ext_autoupdate/from_1.3_to_1.4.php
1.9 /install/autoupdate/from_1.8_to_1.9.php /install/ext_autoupdate/from_1.4_to_1.5.php
2.0 /install/autoupdate/from_1.9_to_2.0.php /install/ext_autoupdate/from_1.5_to_1.6.php
2.1 /install/autoupdate/from_2.0_to_2.1.php /install/ext_autoupdate/from_1.6_to_1.7.php
2.2 /install/autoupdate/from_2.1_to_2.2.php /install/ext_autoupdate/from_1.7_to_2.2.php
2.3 /install/autoupdate/from_2.2_to_2.3.php /install/ext_autoupdate/from_2.2_to_2.3.php
2.4 /install/autoupdate/from_2.3_to_2.4.php /install/ext_autoupdate/from_2.3_to_2.4.php
2.5 /install/autoupdate/from_2.4_to_2.5.php /install/ext_autoupdate/from_2.4_to_2.5.php
2.6 /install/autoupdate/from_2.5_to_2.6.php /install/ext_autoupdate/from_2.5_to_2.6.php
2.7 /install/autoupdate/from_2.6_to_2.7.php
/install/autoupdate/data_prepare_from_2.6_to_2.7.php
/install/ext_autoupdate/from_2.6_to_2.7.php
2.8 /install/autoupdate/from_2.7_to_2.8.php /install/ext_autoupdate/from_2.7_to_2.8.php
2.9 /install/autoupdate/from_2.8_to_2.9.php /install/ext_autoupdate/from_2.8_to_2.9.php
3.0 /install/autoupdate/from_2.9_to_3.0.php /install/ext_autoupdate/from_2.9_to_3.0.php
3.1 нет /install/ext_autoupdate/from_3.0_to_3.1.php
3.2 /install/autoupdate/from_3.1_to_3.2.php /install/ext_autoupdate/from_3.1_to_3.2.php